Intro

Tratar de instalar un paquete en debian 6 y que el sistema se queje porque no encuentra la fuente es bastante frustrante. Si, ya se que hay que actualizar a debian 8, que la versión 6 ya está muy pasada. Pero si tienes una aplicación web que funciona con la versión de php que tiene instalada por defecto el sistema (y la de MySQL) actualizar a otra da un poco de pavor.

El caso es que me he puesto a ver si conseguía modificar el sistema de traducción de la aplicación por algo menos artesanal y más ‘de programador serio’ y necesitaba instalar el gettext, pero cuando lo he intentado el sistema me ha dicho que no podía instalar las dependencias.

He buscado y al final he encontrado la forma de seguir instalando programas en un debian 6.

 

Cambiar las fuentes

Obviamente lo único que hemos de hacer es cambiar las fuentes de donde el sistema ‘bebe’ para instalar o actualizar programas.

Googleando un poco (para variar) he encontrado la siguiente pregunta en la página de debian Squeeze:

Q) Now that squeeze is archived, how do I get packages for it?

La respuesta es la siguiente:

Use the following in your sources.list:

The second line will fail with an “expired” type message, so you also need to add the following in /etc/apt/apt.conf (create it if it doesn’t already exist):

Para evitar errores de not fouund, comenté las siguientes líneas en /etc/apt/sources.list.d/sources.list:

Y todo listo.

debian-logo